INse

Excellence in KVM and Video

Draco tera — Tera Tool

Release Notes

System Requirements

Supported OS Required software
Microsoft Windows (8, 7, XP): 32bit & 64bit SUN JRE 6+ (Update 34)
Mac OS X (10.6, 10.7): Intel platform, 32bit & 64bit Apple JRE 6+
Changes

Date Version Change

2014-11-21 3.0.3.2 Improvements:
e Firmware Panels: Improved reload performance

Fixed bugs:
» Update Ext Firmware - Parallel Update: Fixed update duration
calculation

2014-11-13 3.03.1 Improvements:

» Save Status : Improved functionality

» Update Ext Firmware - Sequential Update : Improved
performance

» Grid: Display Master and Sub in tab title

Fixed bugs:
 License Management: Fixed serial number in status zip file in grid
environment

2014-09-15 3.0.3.0 Features and enhancements:

+ Support of EXTICON, EXTDPCON, EXTDPCPU, MATXUNI

» Added new sort buttons to favorites assignment and extender
assignment

Improvements:

e Optimized memory management

» Shutdown Matrix : Improved shutdown message

» Restart Matrix : Changed restart behaviour after matrix firmware
updates

» Optimized data management in Status - Matrix Firmware and
Status - EXT Firmware

» Show offline matrices in a different color in Status - Matrix
Firmware and Status - EXT Firmware

» Added context menu actions to Status — Ext Firmware /
Component View

» Matrix Grid: Added Keep ID option

» System Check : Check Invalid /O Board parameter

Fixed bugs:
» Fixed restart of I/O board in Grid Port View
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2014-07-01

3.021

Improvements :
» Optimized License Management view

Fixed bugs:
» Update EXT Firmware : Fixed calculation of update duration in
parallel update mode

2014-06-13

3.0.2.0

Features and enhancements:

 Validation of EXTMSD / EXTIMSD version in System Check and
Extender Firmware View

» Added Drag&Drop support in Extender Assignment , Favorites
and CPU Access Control View

» Added save button to toolbar to save configuration changes
instantly on the matrix

» Syslog : Added new filter options and search functions

Improvements:

» Save Status saves all serials and firmware versions within a Matrix
Grid

» Optimized loading time in Status EXT Firmware

Fixed bugs:

 Fixed possible NullPointerException in syslog

» Reload port status before executing Save Status

» Multi-Screen Control:  Show correct values in Enabled column

2014-04-11

3.0.1.0

Features and enhancements:

» Support of Matrix Shutdown

» Added Device Finder functionality

Added Redundancy parameter to System Data and CON Devices
Added OSD Position defaults to EXT Units — Extender OSD Data

Improvements:

Added toolbar button text

» Added scrollbar to Multi-Screen Control panel

Added MAC-Address textfield to System - Network
Optimized initialization process of Matrix View

Allow activation of Echo Only and Synchronize at once

Fixed bugs:

» Fixed master detection in grid environment

 Fixed blocking of Activate Configuration when executing on
multiple connections at the same time

2014-02-07

3.0.0.0

Features and enhancements:
» Support of Matrix Grid
- Matrix Grid Configuration Wizard
- Grid Port View
- Enhanced Matrix and EXT Firmware View
» Syslog: Support of daily logfiles
Syslog: Added Autostart option
Status — Ext Firmware: New Component View
» Support of Duallink extenders
» Added matrix status LED in statusbar

Improvements:
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» Administration — Activate Configuration : Added version column

» Macros : Toobar buttons replaces context menu

» Macros : Added visual overview of various configured macros

 Definition panels: New text for New and Delete buttons

e System — Network: Show current IP Address in DHCP mode

» Configuration Report:  Now supports the saving of System
settings

» Optimized performance on config reload

» Changed sorting order in syslog trace file

» Improved extender update process

» Assignment — Multi-Screen Control: ~ Show restart /O board
dialog

Fixed bugs:
« Assignment — Multi-Screen Control:  Fixed enable/disable bug
« Extender Assignment: Fixed sorting of port column

2013-11-28 1.95 Features and enhancements:
* Definition — EXT Units : Support of new Video Mode 1280x800.
* Definition — CON Device : New Parameter Port Mode.
2013-09-04 194 Features and enhancements:
» System - System Data : New parameter Echo Only
Improvements:
» Support of Universal 1/0 boards and extender
» Added Select All checkbox to Assign Settings to... / Copy
Settings from...
Fixed bugs:
* Fixed displaying of warnings/errors in Status — EXT Firmware
* Fixed selection of first table row in Multi-Screen Control
 Fixed wrong description in System Validation
2013-06-26 1.9.3 Features and enhancements:
» System - System Data : New parameter Load Default
Improvements:
» Improved Factory Reset of I/O Boards action
« Differentiation between connection error and user/pwd error in
connection dialog
» Optimized protocol messages after firmware upload and reload
» Show Message on Syslog startup when syslog port is already in
use
 Allow changes in Ext Units - General OSD Data for custom CON
ports
Fixed bugs:
» Fixed Save Status on Mac OS X
« Fixed reload after firmware upload
2013-06-14 1.9.2 Features and enhancements:

» System Check

Improvements:
» Syslog supports autostart function
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* Improved FTP communication

» Improved upload of extender firmware

» Support of Keyboard layout English GB, 166

» Extender ID is no longer allowed to be changed in
Definition — EXT Units

 Additional tooltips to System Data — OSD Data

» Save Status includes trace.log and ioboard.log

» Support of Login User macro

» Improved table filter option in definition panels

» Improved displaying of warnings/errors in Status — EXT Firmware

» Support of Factory Reset

Fixed bugs:

« Password field in Connect Dialog supports special characters

* When configuration mode is activated, the context menu of the
macro table is enabled

« Fixed time display in update progress bar

» Fixed AppName position in syslog

2013-03-15 191 Fixed bugs:
» Fixed ACL Assignment in CON Devices
 Fixed setting of date in Date and Time
2013-02-15 1.9.0 Features and enhancements:

» Support of SNTP protocol

» Set date and time in Date and Time

* New parameters for a CPU Device Scanner in CON Devices

 Support of Multi-Screen Control

* Display I/O Board and CPU Board serial numbers in Matrix
Firmware

» Support of SNMP Trap configuration

» Restart of I/O Boards by using the Matrix View context menu

» New parameter Enable Old Echo to support old echo format

Improvements:

» Added new parameters to Configuration Report , optimized
representation of EXT Units reports

« Full switching support of custom extenders in Matrix View

» Additional video mode in Ext Units — General OSD Data in a
resolution of 1920 x 1200

» Optimized templates dialog in CPU Devices and CON Devices

» Added Online Configuration Mode to toolbar

» Optimized sorting in Virtual CON Devices and Virtual CPU Devices

» Support of French(CH) as a new keyboard layout

» Syslog will continue running in the background, if syslog tab is
closed

» Syslog log files support csv format

Fixed bugs:

» Fixed commit of changes in Copy Settings From dialog when
Online Configuration Mode s activated

 Fixed cancel of changes in checkboxes

« Changes in IP text field leads to activation of apply buttons

+ Fixed crash in Save Status
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2012-12-13

18.1

Improvements:

» Improved visualization of Online Configuration Mode
* Allow user without password

» Improved handling of corrupt configurations

Fixed bugs:
 Fixed broken Custom Extender Assignment in CPU Devices and
CON Devices

* Removed double call of Modification Detected Dialog in
Definition Panels after pressing Cancel Button

2012-11-28

1.8.0

Features and enhancements:

 Parallel Extender Update

» Online Configuration Mode

» Switching per Drag & Drop in Matrix View

 Disconnect Console from CPU in Matrix View

» Support of Syslog Protocol

 License management implemented

* Number of Favorites increased to 16

« Distributed firmware update of extenders via 10 boards

» Extender OSD Data tab to change extender OSD settings in EXT
Units

» FIX Frame option for CPU devices adds a semi-transparent colored
frame to the video

 Private access is now a property of the CPU device and is also
supported by Macros and Favorites

 Basic support of SNMP service

» Macros offer simplified Push/Get functions

Improvements:

» Added Definition - User to Configuration Reports

» Improved Extended Switch View, supports Private Mode

» Improved Presets View, supports Private Mode

» Drag & Drop support for Firmware files (*.tfw, *.efw)

» Replaced assignment dialog by assignment wizard in Definition
panels

» Function Reset Matrix renamed to Factory Reset

+ Function Draco Service renamed to API Service

Fixed bugs:
« Remove all connections when deleting CPU Device
» Enable all OSD checkboxes in Update Matrix Firmware

2012-08-01

171

Features and enhancements:
» Support of TERA048c

Improvements:

» Added port number column to Extender Assignment table

» Show Matrix View in Online Mode on startup

» New Custom Template for fixed port extender in Definition — EXT
Units

Fixed bugs:
« Fixed focus problems in Download Dialog
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2012-06-06

1.7.0

Features and enhancements:

» Configuration Reports in PDF format

» Enable/Disable Automatic reload of Matrix View
» Show network connection state in Matrix View

» Show/Hide Port numbers in Matrix View

Improvements:

» Improved usability and layout of EXT Firmware

» Improved usability and layout of Update EXT Firmware

» Improved Standard and Expert View for extender types in Ext Units
» Improved Upload and Download Dialog

Fixed bugs:

 Fixed bug which occurred during data communication when Echo
Mode is activated

« Fixed problems with Video-only connections in Presets

 Fixed error in configuration file upload and download with JRE 7+
and Windows 7

2012-04-18

1.6.2

Features and enhancements:

» Demo mode (Connection to IP address 255.255.255.255 opens
files named demo.dtf and demo.dtc in the tool directory for demo
purposes)

Improvements:

» Supports switching of Virtual CON Devices

» Added Private Mode state to Matrix View

» Show Invalid Ports in Matrix View , e.g. when a Fixed Port
Extender is connected to port which is not a fixed port

» Download of config files requires admin rights

» Show assigned device of a Fixed Port Extender in MatrixView
propertysheet

» Changes in Optionsdialog will be activated without application
restart

» Renamed Switch Macros to Presets

« Drag & Drop support for config files (mac os & windows)

Fixed bugs:

e Load Firmware displays Matrix View again

 Configuration upload with a wrong password shows a error
message

« Disabled upload of firmware files (*.dtf)

« Avoid sending of connection data in Extended Switch in case of
cancelling CPU Device selection

2012-03-09

161

Improvements:

* New connection management between application and Matrix
» Added legend to Matrix View

» Supports new module and extender names

» Upload of config files requires admin rights

Fixed bugs:

* No blocking of application when closing tab

» Activation of Enable New User, Enable New CON enables all
CPUs for a new user or new console
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2012-02-10 1.6.0 Features and enhancements:
* CON Macros
* User Macros

Improvements:

* Show Slot ID in Matrix View

« Addition of IP Address column to Activate Configuration table

« Expand Matrix Firmware views by default

« Different firmware states are colored in Matrix Firmware views

» Show CPU Devices in Favorites - Available CPU table in
dependency of Console ACL'’s state

» Optimized matrix restart

« Addition of tooltip to cpu port in Matrix View

Fixed bugs:
« Allow Cancel on changes in User Favorites
« Fixed refresh of Update Ext Firmware

2011-12-22 15.0 Features and enhancements:

» Switch Macros

» Optionsdialog for default settings

» Encrypted configuration files

» System — Access: New parameters Enable New User and Enable
New CON

Reset button to reset all connections in Extended Switch

Improvements:

» Redesign of Matrix View representation

« Selection behaviour of 10-Boards in Update Matrix Firmware

» Optimized performance when creating new devices in big
configurations

» Renamed and reordered task names

« Optimized representation on Mac

« Added multiselection in overview tables

» Added row number in overview tables

» Added port to Extender tables

* Added columns Current Version and Current Date to Update
Matrix Firmware and Update EXT Firmware update views

Fixed bugs:

* Fixed context menus on Mac

* Removed Fixed Ports from gobal view of Update EXT Firmware

« Fixed blocking of Definition views when selecting Hide Devices
w/o Extender Assignment checkbox in Extended Switch

2011-11-10 1.4.2 Improvements :

» Reduced time for loading configuration

« Reduced time for extender update by restarting matrix instead of
restarting 10 cards

2011-11-07 14.1 Improvements:

* Green shared icon added to Matrix View and Switch Console to
CPU

 Virtual CPUs added to Favorites list
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Fixed bugs:
» Assignment of real to virtual consoles added to online mode
 Fixed treeview update when expanding and collapsing per mouse
in Matrix Firmware and Update Matrix Firmware
2011-11-04 1.4.0 Features and enhancements:
» CPUs are configurable as favorites in User Data and CON Devices
» Connect with hostname or ip address in connection dialog
* ip is replaced by hostname in defaults.cfg
» New icons in Matrix View and Switch Console to CPU to display
Shared Access
» Users are pointed out to save changes before program exit
» Remember last selection in template dialog of EXT Units , CPU
Units, CON Devices and User Data
» Restrict access rights of Power User to Matrix View and Switch
Console to CPU panels
» Checkbox to hide devices without extender assignment in Switch
Console to CPU
Improvements:
» Context menu added to Switch Console to CPU
Fixed bugs:
« Enter does not work in finish panel of import/export dialog
« Fixed Offline configuration of Video Only Access in Switch
Console to CPU
 Fixed Configuration of KVM sharing in Switch Console to CPU
when Auto Send is disabled
« Dialog of Upload action in toolbar now appears every time
« If there are changes when closing the application, only one save
dialog will be shown
2011-10-13 1.3.2 Fixed bugs:
e Update Matrix Firmware , Update Ext Firmware : Deselect
disabled checkboxes in column Update
* Virtual to Real CPU assignment does not work
2011-10-11 1.3.1 Improvements:
« Optimized Extender Firmware update process
» Added Service Mode state in Matrix Firmware view
« Show wait cursor during expanding treeview in Matrix Firmware
view
Fixed bugs:
* Removed repeating update in Single Firmware Update
* Wrong Fixed Port validation in Ext Units
» Fixed Collapsing of Matrix Firmware view after directory change
 Fixed wrong background error color for Upgrade Modules in
Update EXT Firmware tables
« Non Administration panels are disabled in Service Mode
« Fixed broken support dialog
2011-09-26 1.3.0 Features and enhancements:
» Supports Extender Updates
» CON Device: New parameter, LOS Frame
 Relative pathnames in defaults.cfg
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» Improved directory management in FileChooser-Dialogs
» System Data Panel : Slave definition revised & clarified

Fixed bugs:

» Restart Switch needs admin rights

« Switch Console to CPU : Fixed KVM sharing bug in Auto Send
mode

» Update Matrix Firmware : Fixed Update problem when a default
path is selected

» Fixed communication errors in LAN Echo mode

2011-08-19 1.2.0 Features and enhancements:

» Loading and saving of firmware status

* Filterable dropdown box in tables

« Auto send function in Switch Console to CPU , Real to Virtual
Console and Virtual to Real CPU

« Matrix View : Port number is flashing when selected

» Firmware Update : Supports OSD and HID updates

« Drag & drop file open support (windows only)

« CON Device : New parameters, Allow Login and Force Login

« Ext Units : New parameter, Video Mode

 Restart switch action

Fixed bugs:
 Fixed selection problem in sorted and filtered tables
» Fixed incomplete reload in some views
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